Example mail to request your host updating your PHP version

Category

Support »
Last update: 21 March, 2017

The single most important reason for us to want to increase the minimum PHP requirement is security: PHP versions 5.2 through to 5.5, while still actively in use on millions of sites, no longer get security updates. The second reason is a ridiculous increase in speed. Therefore, we recommend updating to PHP 7. You can read our whipping your host into shape article for more information.

If you are already on PHP 7 you don't have to do anything. If you are on PHP 5.6 we recommend updating as well. You can check in our PHP 7 KB article whether your site is ready for PHP 7.

Most hosts have documentation where they explain how you can update your PHP version yourself. Check our update your PHP version KB article if your host is listed. If you can't find one or your host doesn't have one, you can use this letter to send to your host.

Hi,

For security reasons and an increase in speed I want to update the PHP version of my WordPress website to PHP 7. WordPress also strongly recommends the latest version of PHP on their requirements page, https://wordpress.org/about/requirements/.

More information about currently supported versions of PHP can be found here: http://php.net/supported-versions.php.

I've heard that sometimes a website can break when updating the PHP version. Can you assist me and update my site safely to PHP 7?

Thanks!

We always advise creating a backup of your website before making any major changes.

Was this article helpful? ·