Plugin Requirements

Last update: 21 May, 2018

Our hosting requirements are the same as the core WordPress program:

  • PHP version 7.2 or greater
  • MySQL version 5.6 or greater OR MariaDB version 10.0 or greater

Requirements for Premium Plugins

In addition to the general requirements above, we recommend running current versions of everything on your site from applications to plugins. Our support team will not support anything but the latest and the prior to last version of WordPress core and our plugins. Learn why here.

To receive update notifications for premium plugins, your host must support:

  • cURL 7.20.0 or greater
  • OpenSSL 0.9.8j or greater
  • TLS 1.0 or greater
  • Do not use SSL v3
If your web host is running a cURL version older than 7.20.0, you may notice a warning in your SEO Dashboard. If your subscription activates successfully, an outdated cURL version is not an immediate cause for concern but should be updated as soon as possible. Learn more here.

Was this article helpful? ·